Algoritmo em VisualG – Reajustando o salário de 584 funcionários

Algoritmo em VisualG para reajustando o salário de 584 funcionários de uma empresa de acordo com os seguintes critérios:

a) 50% para aqueles que ganham menos do que três salários mínimos;
b) 20% para aqueles que ganham entre três até dez salários mínimos;
c) 15% para aqueles que ganham acima de dez até vinte salários mínimos;
d) 10% para os demais funcionários.

Continue reading Algoritmo em VisualG – Reajustando o salário de 584 funcionários

Algoritmo em VisualG indica se esta apta ou não para serviço militar

Algoritmo em VisualG que ler os dados de N pessoas (nome, sexo, idade e saúde) e informe se está apta ou não para o serviço militar obrigatório.

algoritmo "ServM"
// Função: Apta para serviço militar
// Autor : Airton Almeida
// Data : 25/11/2013
// Seção de Declarações 
var
programa, idade, apto: inteiro
nome, sexo, saude, opc: caractere
totApto, total: inteiro
inicio
// Seção de Comandos 
programa <- 1
enquanto programa = 1 faca
    limpatela
    apto <- 1
    saude <- "B"
    total <- total + 1
    escreva("Digite o nome: ")
    leia(nome)
    escreva("Digite o sexo (M/F): ")
    leia(sexo)
    escreva("Digite a idade: ")
    leia(idade)
    se idade < 18 entao
        apto <- 0
    fimse
    escreval("Digite o estado de saúde: ")
    escreva("(B) Bom - (R) - Ruim - ")
    leia(saude)
    se saude = "R" entao
        apto <- 0
    senao
        se saude <> "B" entao
            apto <- 0
        fimse
    fimse
    se apto = 1 entao
        totApto <- totApto + 1
    fimse
    escreval("Deseja continuar filtrando (S/N)? ")
    leia(opc)
    se opc = "N" entao
        programa <- 0
    fimse
fimenquanto
limpatela
escreval("Resumo geral: ")
escreval("Foram filtrados: ",total," pessoas")
escreval("Aptos: ",totApto)
escreval("")

fimalgoritmo

Algoritmo em VisualG que executa os seguintes testes lógicos:

(a) Verifica se o numero é par ou ímpar
(b) Verifica se o numero é positivo ou negativo
(c) Verifica se o numero é divisível(multiplo) ou não de 3
(d) Verifica se o numero é divisível(multiplo) ou não de 4
(e) Verifica se o numero é divisível(multiplo) ou não de 5
(f) Verifica se o numero é divisível(multiplo) ou não de 7
(g) Verifica se o numero esta dentro ou fora da faixa de +10 a +100

Ex: Se for digitado o valor -35 a saída será:

Este numero é ímpar
Este numero é negativo
Este numero não é múltiplo de 3
Este numero não é múltiplo de 4
Este numero não é múltiplo de 5
Este numero não é múltiplo de 7
Este numero não esta na faixa de +10 a +100

Continue reading Algoritmo em VisualG que executa os seguintes testes lógicos:

Algoritmo em VisualG que ler 1 a 5 e transforma em extenso

—– Início do código ———

algoritmo “Extenso”
// Função : Ler número de 1 a 5 e escreva por extenso.
// Autor : Airton Almeida
// Data : 18/02/2013
// Seção de Declarações
var
numero: inteiro
inicio
// Seção de Comandos
escreva(“Digite um número de 1 a 5: “)
leia(numero)
escolha numero
caso 1
escreval(“Um”)
caso 2
escreval(“Dois”)
caso 3
escreval(“Três”)
caso 4
escreval(“Quatro”)
caso 5
escreval(“Cinco”)
outrocaso
escreval(“Número Inválido!!!”)
fimescolha

————- Fim do código ————–