Algoritmo em VisualG que executa os seguintes testes lógicos:

(a) Verifica se o numero é par ou ímpar
(b) Verifica se o numero é positivo ou negativo
(c) Verifica se o numero é divisível(multiplo) ou não de 3
(d) Verifica se o numero é divisível(multiplo) ou não de 4
(e) Verifica se o numero é divisível(multiplo) ou não de 5
(f) Verifica se o numero é divisível(multiplo) ou não de 7
(g) Verifica se o numero esta dentro ou fora da faixa de +10 a +100

Ex: Se for digitado o valor -35 a saída será:

Este numero é ímpar
Este numero é negativo
Este numero não é múltiplo de 3
Este numero não é múltiplo de 4
Este numero não é múltiplo de 5
Este numero não é múltiplo de 7
Este numero não esta na faixa de +10 a +100

var
num:inteiro
inicio
// Seção de Comandos
escreval ("Digite um número para que o programa o analise")
leia (num)
se (num) MOD 2 = 0 entao
   escreval ("Este número é par")
senao
   escreval ("Este número é ímpar")
fimse
se num >= 0 entao
   escreval ("Este número é positivo")
senao
   escreval ("Este número é negativo")
fimse
se (num) MOD 3 >= 1 entao
   escreval ("Este número não é múltiplo de 3")
senao
   escreval ("Este número é múltiplo de 3")
fimse
se (num) MOD 4 >= 1 entao
   escreval ("Este número não é múltiplo de 4")
senao
   escreval ("Este número é múltiplo de 4")
fimse
se (num) MOD 5 >= 1 entao
   escreval ("Este número não é múltiplo de 5")
senao
   escreval ("Este número é múltiplo de 5")
fimse
se (num) MOD 7 >= 1 entao
   escreval ("Este número não é múltiplo de 7")
senao
   escreval ("Este número é múltiplo de 7")
fimse
se (num >= 10) e (num <= 100) entao
   escreval ("Este número esta na faixa de +10 a +100")
senao
   escreval ("Este número não esta na faixa de +10 a +100")
fimse
fimalgoritmo

Imagine o algoritmo por trás desse vídeo. Não deixe de assistir!

Share Button
Carlos Eduardo

Sem comentários!!!!!!!
simplesmente fantástico.

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Obrigatório * Time limit is exhausted. Please reload CAPTCHA.