Algoritmo em visualg para calcular média de notas

Algoritmo em visualg que calcula média de três notas do aluno e informa se o mesmo esta ou não aprovado.

//algoritmo “SNA”
// Função : Verificar se o aluno foi aprovado
// Autor : Airton Almeida
// Data : 11/12/2012
// Seção de Declarações
var
nota1,nota2,nota3,media : real
aluno : caracter
inicio
nota1 := 11
nota2 := 11
nota3 := 11
escreva(“Digite o nome do aluno: “)
leia(aluno)
escreval(“————————————————-”)
enquanto nota1 > 10 faca
     escreva(“Entre com a Nota 01: “)
    leia(nota1)
fimenquanto
enquanto nota2 > 10 faca
     escreva(“Entre com a Nota 02: “)
     leia(nota2)
fimenquanto
enquanto nota3 > 10 faca
     escreva(“Entre com a Nota 03: “)
     leia(nota3)
fimenquanto
media <- (nota1+nota2+nota3)/3
escreval(“——————————————–”)
se media < 7 entao
       escreval(“O aluno “,aluno,” foi reprovado por ter tirado a média de: “,media)
   senao
     escreval(“O aluno “,aluno,” foi aprovado com nota média de: “,media)
fimse
escreval(“——————————————–”)
fimalgoritmo

Tendo um tempinho, assista a este vídeo.

Share Button

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Obrigatório * Time limit is exhausted. Please reload CAPTCHA.